BehaviorType Enumeration

An enumerated type listing all the behavior type for MEP Components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum BehaviorType
Members
Member nameValueDescription
Invalid0 BehaviorType is Invalid
Normal1 BehaviorType is Normal
Bend2 BehaviorType is Bend
Branch4 BehaviorType is Branch
Intersection8 BehaviorType is Intersection
Inline16 BehaviorType is Inline
BreakInto32 BehaviorType is Break Into
OrientToObject64 BehaviorType is Orient to Object
OrientToCenterLine128 BehaviorType is Orient to CenterLine
OrientToFace256 BehaviorType is Orient to Face
SystemMember512 BehaviorType is System Member
BaseObject1,024 BehaviorType is Base Object
EndCap2,048 BehaviorType is End Cap
Valve4,096 BehaviorType is Valve
Flange8,192 BehaviorType is Flange
MechanicalCoupling16,384 BehaviorType is Mechanical Coupling
VerticalBend32,768 BehaviorType is Vertical Bend
ElectricalBaseObject65,536 BehaviorType is Electrical Base Object
Straight131,072 BehaviorType is Straight
Flex262,144 BehaviorType is Flex
Hanger524,288 BehaviorType is Hanger
Flat_Tap1,048,576 BehaviorType is a flat tap on flat surface, eg. rectangular straight or flat-side of oval straight
Coupling2,097,152 BehaviorType is Coupling
Round_CentreLine_Tap4,194,304 BehaviorType is a round centreline tap on round straight/pipe
Oval_CentreLine_Tap8,388,608 BehaviorType is a round centreline tap on oval straight
Damper16,777,216 BehaviorType is a round centreline tap on oval straight
See Also