CompoundStructureGetRegionsAlongLevel Method |
Returns the ids of the regions encountered as the vertically compound structure is traversed
at a constant height above the bottom a wall to which this structure is applied.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetRegionsAlongLevel(
double height
)
Public Function GetRegionsAlongLevel (
height As Double
) As IList(Of Integer)
public:
IList<int>^ GetRegionsAlongLevel(
double height
)
member GetRegionsAlongLevel :
height : float -> IList<int>
Parameters
- height Double
-
Distance from the bottom of the wall.
Return Value
IListInt32
The ids of the regions intersected by the specified line.
ExceptionsException | Condition |
---|
ArgumentException |
The height is outside valid range. It should be in the range of [0, SampleHeight].
|
See Also