LinkLoadContentGetLinkLoadResult Method |
Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LinkLoadResult GetLinkLoadResult()
Public Function GetLinkLoadResult As LinkLoadResult
public:
LinkLoadResult^ GetLinkLoadResult()
member GetLinkLoadResult : unit -> LinkLoadResult
Return Value
LinkLoadResult
A LinkLoadObject containing the status and other information about an attempt by Revit
to load a Revit link.
RemarksA LinkLoadResult object is included in the LinkLoadContent class so that
IExternalResourceUIServers will have additional information about the status of the
link to display to the user.
The LinkLoadResult is added to the LinkLoadContent object during the load operation,
after the IExternalResourceServer LoadResource method has been called.
Consequently, this method will return NULL if called from the LoadResource method
of an IExternalResourceServer.
See Also