ImageTypeOptionsIsValid Method |
If true the ImageTypeOptions can be used to create or reload an ImageType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValid(
Document document
)
Public Function IsValid (
document As Document
) As Boolean
public:
bool IsValid(
Document^ document
)
member IsValid :
document : Document -> bool
Parameters
- document Document
-
The document.
Return Value
Boolean
Returns True if the options can be used to create or reload an ImageType. False otherwise.
Exceptions
Remarks
This method returns true if all the following checks are true:
- The Path points to a file that is a supported image file type.
- The Path points to a file that is not encrypted, which can happen for PDF files.
- The Path points to a file that contains the specified PageNumber.
- Only imported images are allowed in family documents.
See Also