CustomExporterExport2DForceDisplayStyle Property |
This value tells the exporter of 2D views to force the given display mode for the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DisplayStyle Export2DForceDisplayStyle { get; set; }
Public Property Export2DForceDisplayStyle As DisplayStyle
Get
Set
public:
property DisplayStyle Export2DForceDisplayStyle {
DisplayStyle get ();
void set (DisplayStyle value);
}
member Export2DForceDisplayStyle : DisplayStyle with get, set
Property Value
DisplayStyle
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
Only DisplayStyle::Wireframe and DisplayStyle::HLR values are supported.
Default forced value is DisplayStyle::HLR unless the view has DisplayStyle:Wireframe.
See notes for 2D export for views in non-Wireframe display style in [!:Autodesk::Revit::DB::IExportContextBase] and IExportContext2D.
See Also