FilterNumericRuleEvaluatorEvaluate(Double, Double, Double) Method |
Derived classes override this method to implement the test that determines
whether the two given double-precision values satisfy the desired condition or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Evaluate(
double lhs,
double rhs,
double epsilon
)
Public Function Evaluate (
lhs As Double,
rhs As Double,
epsilon As Double
) As Boolean
public:
bool Evaluate(
double lhs,
double rhs,
double epsilon
)
member Evaluate :
lhs : float *
rhs : float *
epsilon : float -> bool
Parameters
- lhs Double
-
A value from an element in the document.
- rhs Double
-
The user-supplied value against which values from the document are tested.
- epsilon Double
-
Defines the tolerance within which two values may be considered equal.
Return Value
Boolean
True if the given arguments satisfy the condition, otherwise false.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for lhs is not finite
-or-
The given value for lhs is not a number
-or-
The given value for rhs is not finite
-or-
The given value for rhs is not a number
-or-
The given value for epsilon is not finite
-or-
The given value for epsilon is not a number
|
Remarks
The arguments may be thought of as the left and right operands of a
binary expression; for example, "a < b", "x >= 100", etc. The left
operand comes from an element in the Revit document (e.g., the value
of a parameter.) The right operand is supplied by the user when
creating the filter that contains the rule that uses this evaluator.
See Also