WorksetTableGetActiveWorksetId Method |
Returns the active workset's WorksetId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic WorksetId GetActiveWorksetId()
Public Function GetActiveWorksetId As WorksetId
public:
WorksetId^ GetActiveWorksetId()
member GetActiveWorksetId : unit -> WorksetId
Return Value
WorksetId
WorksetId of the active workset.
Examplepublic Workset GetActiveWorkset(Document doc)
{
WorksetTable worksetTable = doc.GetWorksetTable();
WorksetId activeId = worksetTable.GetActiveWorksetId();
Workset workset = worksetTable.GetWorkset(activeId);
return workset;
}
Public Function GetActiveWorkset(doc As Document) As Workset
Dim worksetTable As WorksetTable = doc.GetWorksetTable()
Dim activeId As WorksetId = worksetTable.GetActiveWorksetId()
Dim workset As Workset = worksetTable.GetWorkset(activeId)
Return workset
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also