WallGetWrappingLocationAsCurveParameter Method |
Gets the non-normalized (actual) curve parameter of the location.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetWrappingLocationAsCurveParameter(
int locationIndex
)
Public Function GetWrappingLocationAsCurveParameter (
locationIndex As Integer
) As Double
public:
double GetWrappingLocationAsCurveParameter(
int locationIndex
)
member GetWrappingLocationAsCurveParameter :
locationIndex : int -> float
Parameters
- locationIndex Int32
-
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.
Return Value
Double
The non-normalized (actual) curve parameter value on the curve.
Exceptions
Remarks
If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException.
See Also