DocumentConvertDetailToModelCurves Method |
Converts a group of DetailCurves to equivalent ModelCurves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ModelCurveArray ConvertDetailToModelCurves(
View view,
DetailCurveArray detailCurves
)
Public Function ConvertDetailToModelCurves (
view As View,
detailCurves As DetailCurveArray
) As ModelCurveArray
public:
ModelCurveArray^ ConvertDetailToModelCurves(
View^ view,
DetailCurveArray^ detailCurves
)
member ConvertDetailToModelCurves :
view : View *
detailCurves : DetailCurveArray -> ModelCurveArray
Parameters
- view View
- The view where the new lines will be created.
The lines are projected on the view workplane.
The view workplane must be parallel to the view plane.
- detailCurves DetailCurveArray
- The detail curve array to be converted.
Return Value
ModelCurveArray
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument is .
|
ArgumentException |
Thrown when the given detail lines are not visible in the given view.
Thrown when the detail lines are not in the same view or not parallel to the given view.
|
InvalidOperationException |
Thrown when one or more curves could not be successfully converted.
|
RemarksThis operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.
See Also