TransformScaleBasisAndOrigin Method |
Scales the basis vectors and the origin of this transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform ScaleBasisAndOrigin(
double scale
)
Public Function ScaleBasisAndOrigin (
scale As Double
) As Transform
public:
Transform^ ScaleBasisAndOrigin(
double scale
)
member ScaleBasisAndOrigin :
scale : float -> Transform
Parameters
- scale Double
- The scale value.
Return Value
TransformThe transformation equal to the composition of the two transformations.
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when the specified value is an infinite number.
|
Remarks
The resulting transformation is equivalent to the application of this transformation
and then the uniform scale, in this order.
See Also