RevitLinkTypeAttachmentType Property |
The attachment/overlay status of this link.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic AttachmentType AttachmentType { get; set; }
Public Property AttachmentType As AttachmentType
Get
Set
public:
property AttachmentType AttachmentType {
AttachmentType get ();
void set (AttachmentType value);
}
member AttachmentType : AttachmentType with get, set
Property Value
AttachmentType
AttachmentType.Overlay if this link is an overlay,
AttachmentType.Attachment if this link is an attachment.
Exceptions
Remarks"Attachment" links are considered to be part of their parent
link and will be brought along if their parent is linked into
another document. "Overlay" links are only visible when their
parent is open directly.
For example: A user has a file B which contains a link C, and
they wish to link B into another file, A. If C is an overlay, C
will not be loaded into A. If C is an attachment, then C will
be loaded into A along with B.
See Also