UpdaterRegistryRemoveDocumentTriggers Method |
Removes all triggers associated with specified document and Updater
Does not unregister updater.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void RemoveDocumentTriggers(
UpdaterId id,
Document document
)
Public Shared Sub RemoveDocumentTriggers (
id As UpdaterId,
document As Document
)
public:
static void RemoveDocumentTriggers(
UpdaterId^ id,
Document^ document
)
static member RemoveDocumentTriggers :
id : UpdaterId *
document : Document -> unit
Parameters
- id UpdaterId
-
Id of specified updater
- document Document
-
Document for which to remove triggers
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The updater's owner's AddIn does not match the currently active AddIn.
-or-
RemoveDocumentTriggers called while executing an updater.
|
See Also