BuildingOperatingYearScheduleGetScheduleForDay Method |
Gets the BuildingOperatingDaySchedule for this day of the year.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BuildingOperatingDaySchedule GetScheduleForDay(
DateTime day
)
Public Function GetScheduleForDay (
day As DateTime
) As BuildingOperatingDaySchedule
public:
BuildingOperatingDaySchedule^ GetScheduleForDay(
DateTime day
)
member GetScheduleForDay :
day : DateTime -> BuildingOperatingDaySchedule
Parameters
- day DateTime
-
The day of the year. The value must be in 2023 (the template year) and have the time zone set to gmt/utc.
Time values will be ignored.
Return Value
BuildingOperatingDaySchedule
The schedule used on that day.
Exceptions
Remarks
The day argument must be in 2023 to match the template year in the user interface calendar: it has 365 days and starts on a Sunday.
See Also