AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method |
Factory method - creates analysis display style object of type Deformed Shape for the given document.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
Document document,
string name,
AnalysisDisplayDeformedShapeSettings deformedShapeSettings,
AnalysisDisplayColorSettings colorSettings,
AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
document As Document,
name As String,
deformedShapeSettings As AnalysisDisplayDeformedShapeSettings,
colorSettings As AnalysisDisplayColorSettings,
legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
Document^ document,
String^ name,
AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings,
AnalysisDisplayColorSettings^ colorSettings,
AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
document : Document *
name : string *
deformedShapeSettings : AnalysisDisplayDeformedShapeSettings *
colorSettings : AnalysisDisplayColorSettings *
legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle
Parameters
- document Document
-
Document for which analysis display style object is created.
- name String
-
Name of the analysis display style within the %document%.
- deformedShapeSettings AnalysisDisplayDeformedShapeSettings
-
Deformed Shape settings for the style.
- colorSettings AnalysisDisplayColorSettings
-
Color settings for the style.
- legendSettings AnalysisDisplayLegendSettings
-
Legend settings for the style.
Return Value
AnalysisDisplayStyle
New analysis display style object.
Exceptions
See Also