PerformanceAdviserGetElementFilterFromRule(Int32, Document) Method |
Retrieves a filter to restrict elements to be checked.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementFilter GetElementFilterFromRule(
int index,
Document document
)
Public Function GetElementFilterFromRule (
index As Integer,
document As Document
) As ElementFilter
public:
ElementFilter^ GetElementFilterFromRule(
int index,
Document^ document
)
member GetElementFilterFromRule :
index : int *
document : Document -> ElementFilter
Parameters
- index Int32
-
The rule index to get information for.
- document Document
-
Document for which performance problems are being checked.
Return Value
ElementFilter
The filter to restrict elements to be checked.
Exceptions
See Also