MechanicalSystemTypeCreate Method |
Creates a new instance of a mechanical system type and adds it to the document.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MechanicalSystemType Create(
Document ADoc,
MEPSystemClassification systemClassification,
string name
)
Public Shared Function Create (
ADoc As Document,
systemClassification As MEPSystemClassification,
name As String
) As MechanicalSystemType
public:
static MechanicalSystemType^ Create(
Document^ ADoc,
MEPSystemClassification systemClassification,
String^ name
)
static member Create :
ADoc : Document *
systemClassification : MEPSystemClassification *
name : string -> MechanicalSystemType
Parameters
- ADoc Document
-
The document where the element will be created and added.
- systemClassification MEPSystemClassification
-
The classification for the mechanical system type to be created
- name String
-
The name of the mechanical system type to be created.
Return Value
MechanicalSystemType
The newly created mechanical system type element.
Exceptions
See Also