FilteredElementCollectorWherePasses Method |
Applies an element filter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredElementCollector WherePasses(
ElementFilter filter
)
Public Function WherePasses (
filter As ElementFilter
) As FilteredElementCollector
public:
FilteredElementCollector^ WherePasses(
ElementFilter^ filter
)
member WherePasses :
filter : ElementFilter -> FilteredElementCollector
Parameters
- filter ElementFilter
-
The element filter.
Return Value
FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned
so you can chain multiple calls together in one line.
Exceptions
Remarks
The filter will be added as an additional condition that all filtered elements must pass.
If you have an active iterator to this collector it will be stopped by this call.
See Also