ParameterFilterElementSetElementFilter Method |
Sets the rules that must be satisfied for a given element to pass this filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SetElementFilter(
ElementFilter elementFilter
)
Public Function SetElementFilter (
elementFilter As ElementFilter
) As Boolean
public:
bool SetElementFilter(
ElementFilter^ elementFilter
)
member SetElementFilter :
elementFilter : ElementFilter -> bool
Parameters
- elementFilter ElementFilter
-
An ElementFilter representing the rules. It may be an ElementParameterFilter
representing a conjunction of one or more FilterRules, or an ElementLogicalFilter
(of type LogicalAndFilter or LogicalOrFilter) representing a logical combination
of FilterRules, using AND/OR operations.
Return Value
Boolean
Returns true if this ParameterFilterElement was changed, false if not.
It will not be changed if the input rules are equivalent to the ParameterFilterElement's
existing rules.
Exceptions
Remarks
Note that in some situation, calling GetElementFilter after calling SetElementFilter
may return an ElementFilter that is structurally different from the one passed as input
to SetElementFilter. For example, if the input ElementFilter contains an ElementParameterFilter
that contains more than one FilterRule, and if the view filters dialog box is used in between
the calls to SetElementFilter and GetElementFilter, the output ElementFilter will use a single
ElementParameterFilter for each of the FilterRules that were bundled in an input ElementParameterFilter.
The two ElementFilters will be logically and functionally equivalent in the sense that any given
Element will either be accepted by both ElementFilters or rejected by both ElementFilters.
See Also