TransactionHasStarted Method |
Determines whether the transaction has been started yet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function HasStarted As Boolean
public:
bool HasStarted()
member HasStarted : unit -> bool
Return Value
Boolean
True if the transaction has already started, False otherwise.
Remarks
A transaction is considered being started after a 'Start' method was called
and until the transaction is either completely committed or rolled back.
HasStarted may return True even after 'Commit' or 'RollBack' was called
if the method returned the TransactionStatus.Pending value.
A transaction can only be Started when HasStarted returns false.
See Also