FamilyManagerMakeInstance Method

Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void MakeInstance(
	FamilyParameter familyParameter
)

Parameters

familyParameter  FamilyParameter
 
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument-"familyParameter"-is .
ArgumentException Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
InvalidOperationException Thrown when there is Type family parameter driven by this parameter. Or trying to make a parameter of image type to instance.
See Also