ParameterSetValueString Method |
Set the parameter value according to the input string.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SetValueString(
string valueString
)
Public Function SetValueString (
valueString As String
) As Boolean
public:
bool SetValueString(
String^ valueString
)
member SetValueString :
valueString : string -> bool
Parameters
- valueString String
- The string that represents the parameter value.
Return Value
BooleanIndicates whether the parameter value is successfully set.
RemarksThe method only applies to parameters of value types.
Examplepublic bool SetWithValueString(Parameter foundParameter)
{
bool result = false;
if (!foundParameter.IsReadOnly)
{
result = foundParameter.SetValueString("-22\'3\"");
}
return result;
}
Public Function SetWithValueString(foundParameter As Parameter) As Boolean
Dim result As Boolean = False
If Not foundParameter.IsReadOnly Then
result = foundParameter.SetValueString("-22'3""")
End If
Return result
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also