SpacingRuleBeltMeasurement Property

On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double BeltMeasurement { get; set; }

Property Value

Double
Exceptions
ExceptionCondition
ArgumentOutOfRangeException Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
InvalidOperationException Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.
Remarks
On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.
See Also