Returns the angle between this vector and the specified vector projected to the specified plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double AngleOnPlaneTo(
XYZ right,
XYZ normal
)
Public Function AngleOnPlaneTo (
right As XYZ,
normal As XYZ
) As Double
public:
double AngleOnPlaneTo(
XYZ^ right,
XYZ^ normal
)
member AngleOnPlaneTo :
right : XYZ *
normal : XYZ -> float
Parameters
- right XYZ
- The specified vector.
- normal XYZ
- The normal vector that defines the plane.
Return Value
DoubleThe real number between 0 and 2*PI equal to the projected angle between the two vectors.
Exceptions
Remarks
The angle is projected onto the plane orthogonal to the specified normal vector,
counterclockwise with the normal pointing upwards.
See Also