Indexed access to coordinates.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double this[
int idx
] { get; }
Public ReadOnly Default Property Item (
idx As Integer
) As Double
Get
public:
property double default[int idx] {
double get (int idx);
}
member Item : float with get
Parameters
- idx Int32
- Use 0 for X, 1 for Y and 2 for Z.
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
Thrown when an attempt is made to access the coordinate
with an index that is larger than 2.
|
See Also