DocumentLoadFamily(String) Method |
Loads an entire family and all its types/symbols into the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool LoadFamily(
string filename
)
Public Function LoadFamily (
filename As String
) As Boolean
public:
bool LoadFamily(
String^ filename
)
member LoadFamily :
filename : string -> bool
Parameters
- filename String
- The fully qualified filename of the Family file, usually ending in .rfa.
Return Value
BooleanTrue if the entire family was loaded successfully into the project, otherwise False.
Exceptions
RemarksLoading an entire family may take a considerable amount of time and memory. It is
recommended that you use one of the LoadFamilySymbol() methods
and only load those symbols that you need.
See Also