OutlineContainsOtherOutline Method |
Determine if this Outline contains another Outline to within tolerance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ContainsOtherOutline(
Outline otherOutline,
double tolerance
)
Public Function ContainsOtherOutline (
otherOutline As Outline,
tolerance As Double
) As Boolean
public:
bool ContainsOtherOutline(
Outline^ otherOutline,
double tolerance
)
member ContainsOtherOutline :
otherOutline : Outline *
tolerance : float -> bool
Parameters
- otherOutline Outline
-
The outline to test for containment.
- tolerance Double
-
The tolerance to use when determining whether the point is contained. Defaults to zero.
Return Value
Boolean
True if this outline contains the given outline, or false otherwise.
Exceptions
Remarks
If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate.
If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.
See Also