StructuralFramingUtilsRemoveEndReference Method |
Resets the end reference of the structural framing element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void RemoveEndReference(
FamilyInstance familyInstance,
int end
)
Public Shared Sub RemoveEndReference (
familyInstance As FamilyInstance,
end As Integer
)
public:
static void RemoveEndReference(
FamilyInstance^ familyInstance,
int end
)
static member RemoveEndReference :
familyInstance : FamilyInstance *
end : int -> unit
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category, non-concrete and joined.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
Exceptions
Remarks
The setback value will be changed as a result of the removal.
See Also