SelectionPickBox(PickBoxStyle, String) Method |
Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Namespace: Autodesk.Revit.UI.SelectionAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PickedBox PickBox(
PickBoxStyle style,
string statusPrompt
)
Public Function PickBox (
style As PickBoxStyle,
statusPrompt As String
) As PickedBox
public:
PickedBox^ PickBox(
PickBoxStyle style,
String^ statusPrompt
)
member PickBox :
style : PickBoxStyle *
statusPrompt : string -> PickedBox
Parameters
- style PickBoxStyle
- Specifies the value that controls the style of the pick box.
- statusPrompt String
- The message shown on the status bar.
Return Value
PickedBoxThe picked box that contains two XYZ points.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException | Thrown when the style is not a recognized value. |
ArgumentNullException | Thrown when the argument statusPrompt is . |
OperationCanceledException | Thrown when the Revit user cancelled this operation.
Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
|
Remarks
The method starts an editor and returns when it finishes. Returns a PickedBox that contains two XYZ points.
See Also