Determine if this Outline contains the specified point to within a tolerance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Contains(
XYZ point,
double tolerance
)
Public Function Contains (
point As XYZ,
tolerance As Double
) As Boolean
public:
bool Contains(
XYZ^ point,
double tolerance
)
member Contains :
point : XYZ *
tolerance : float -> bool
Parameters
- point XYZ
-
The point to test for containment.
- tolerance Double
-
The tolerance to use when determining whether the point is contained. Defaults to zero.
Return Value
Boolean
True if this outline contains the given point, or false otherwise.
Exceptions
Remarks
If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate.
If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.
See Also