HVACLoadBuildingTypeCreate Method |
Creates a building type element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static HVACLoadBuildingType Create(
Document document,
string name
)
Public Shared Function Create (
document As Document,
name As String
) As HVACLoadBuildingType
public:
static HVACLoadBuildingType^ Create(
Document^ document,
String^ name
)
static member Create :
document : Document *
name : string -> HVACLoadBuildingType
Parameters
- document Document
-
The document.
- name String
-
The building type name.
Return Value
HVACLoadBuildingType
The new building type.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
The given value for name is already in use as a building type name.
|
ArgumentNullException |
A non-optional argument was null
|
See Also