SketchGalleryOptions Enumeration

Enumerates all the sketch options.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum SketchGalleryOptions
Members
Member nameValueDescription
SGO_Default0 The default option which means the real option is decided by Revit internally.
SGO_Line1 Sketch a line.
SGO_Rect2 Sketch a rectangle.
SGO_InscribedPolygon3 Sketch an inscribed polygon.
SGO_CircumscribedPolygon4 Sketch a circumscribed polygon.
SGO_Circle5 Sketch a circle.
SGO_Arc3Point6 Sketch a Start-End-Radius arc.
SGO_ArcCenterEnds7 Sketch a Center-Ends arc.
SGO_ArcTanEnd8 Sketch a Tangent-End arc.
SGO_ArcFillet9 Sketch a fillet arc.
SGO_Spline10 Sketch a spline.
SGO_SplineByPoints11 Sketch a spline by points.
SGO_FullEllipse12 Sketch a full ellipse.
SGO_PartialEllipse13 Sketch a partial ellipse.
SGO_PickLines14 Pick lines.
SGO_PickFaces15 Pick faces.
SGO_PickWalls16 Pick walls.
SGO_PickSupports17 Pick supports.
SGO_PickRoofs18 Pick roofs.
SGO_Point19 Pick a point.
SGO_PickPoints20 Pick points.
SGO_PointElement21 Pick point element.
SGO_RunLine22 Sketch a line for a run of stairs.
SGO_RunArcFullStep23 Sketch a Full-Step spiral for a run of stairs.
SGO_RunArcCenterEnds24 Sketch a Center-Ends spiral for a run of stairs.
SGO_LandingSquare25 Sketch a landing square.
SGO_WinderLShape26 Sketch a L-Shape winder.
SGO_WinderPattern27 Pick winder pattern.
SGO_SupportPickLine28 Pick a line to create a support.
SGO_WinderUShape29 Sketch a U-Shape winder.
SGO_LandingWithTwoRuns30 Pick two runs to create a landing.
SGO_SketchRun31 Sketch a run.
SGO_SketchLanding32 Sketch a landing.
See Also