DocumentPrint(ViewSet, View) Method

Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Print(
	ViewSet views,
	View viewTemplate
)

Parameters

views  ViewSet
The set of views which need to be printed.
viewTemplate  View
The view template which apply to the set of views.
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullExceptionThrown when the view set to be printed is .
ArgumentExceptionThrown when the view set contains a element.
ApplicationExceptionThrown when at least one view from the view set could not be printed.
OperationCanceledExceptionThrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also