SlabEdgeAddSegment Method

Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override void AddSegment(
	Reference targetRef
)

Parameters

targetRef  Reference
Segment's reference on which want to be added.
Exceptions
ExceptionCondition
ArgumentNullException This exception will be thrown in following cases: 1. Input targetRef is . 2. Input targetRef is not but contains nothing.
InvalidOperationException This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
ArgumentOutOfRangeException This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges
See Also