RebarShapeDrivenAccessorSetLayoutAsNumberWithSpacing Method |
Sets the Layout Rule property of rebar set to NumberWithSpacing
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLayoutAsNumberWithSpacing(
int numberOfBarPositions,
double spacing,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
Public Sub SetLayoutAsNumberWithSpacing (
numberOfBarPositions As Integer,
spacing As Double,
barsOnNormalSide As Boolean,
includeFirstBar As Boolean,
includeLastBar As Boolean
)
public:
void SetLayoutAsNumberWithSpacing(
int numberOfBarPositions,
double spacing,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
member SetLayoutAsNumberWithSpacing :
numberOfBarPositions : int *
spacing : float *
barsOnNormalSide : bool *
includeFirstBar : bool *
includeLastBar : bool -> unit
Parameters
- numberOfBarPositions Int32
-
The number of bar positions in rebar set
- spacing Double
-
The maximum spacing between rebar in rebar set
- barsOnNormalSide Boolean
-
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar Boolean
-
Identifies if the first bar in rebar set is shown
- includeLastBar Boolean
-
Identifies if the last bar in rebar set is shown
Exceptions
Remarks
When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions,
Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
See Also