TessellatedShapeBuilderResultGetGeometricalObjects Method |
When called the first time, returns geometrical objects which were built.
Later calls will throw exceptions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<GeometryObject> GetGeometricalObjects()
Public Function GetGeometricalObjects As IList(Of GeometryObject)
public:
IList<GeometryObject^>^ GetGeometricalObjects()
member GetGeometricalObjects : unit -> IList<GeometryObject>
Return Value
IListGeometryObject
Geometrical object which were built.
Remarks
Normally an array contains a single geometrical object
corresponding to either 'target' or 'fallback' type', but if
multiple face sets are being built with target/fallback of "AnyGeometry/Mesh",
then a two-element array with both geometry as the 1st element and mesh
as the 2nd can be returned. It happens if some of the face sets require a
fallback processing and some do not.
See Also