ImportPlacement Enumeration

An enumerated type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ImportPlacement
Members
Member nameValueDescription
Site0 Placement at Base Point. Useful for Revit links only. There must be a reference point in order for this option to be valid.
Origin1 Placement at the Origin. If reference point is provided, then the import is placed so the point is at the model's origin. If no point is provided, then the document's origin is matched with the model's origin.
Centered2 Placement at the Center. If reference point is provided, then the import is placed so the point is at the model's center. If no point is provided, then the document's center is matched with the model's origin.
Shared3 Placement with respect to the shared coordinates. Revit Building places the imported geometry according to its location with respect to the shared coordinates between the two files. There must be shared coordinates in a Revit document in order for this option to be valid.
See Also