DrawContextGetClipRectangle Method |
Gets the clip rectangle for the Revit view where rendering takes place. The clip rectangle
is the area currently being redrawn, which may be smaller than the view rectangle.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Rectangle GetClipRectangle()
Public Shared Function GetClipRectangle As Rectangle
public:
static Rectangle^ GetClipRectangle()
static member GetClipRectangle : unit -> Rectangle
Return Value
Rectangle
The clip rectangle.
ExceptionsException | Condition |
---|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also