Transform1D(Double, Double) Constructor |
Constructs the transformation by specifying the scale and the translation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform1D(
double scale,
double translation
)
Public Sub New (
scale As Double,
translation As Double
)
public:
Transform1D(
double scale,
double translation
)
new :
scale : float *
translation : float -> Transform1D
Parameters
- scale Double
-
The scale of the transformation.
- translation Double
-
The translational part of the transformation.
Remarks
1D space is tranformed according to the following formula: t --> scale*t + translation
See Also