TaskDialogExpandedContent Property |
ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string ExpandedContent { get; set; }
Public Property ExpandedContent As String
Get
Set
public:
property String^ ExpandedContent {
String^ get ();
void set (String^ value);
}
member ExpandedContent : string with get, set
Property Value
String
Remarks
If added to a dialog, a Show/Hide toggle button displays at the bottom of the task dialog. The Expanded Content is hidden by default.
This area is used when even more information needs to be relayed to the user than space allows. It is rarely used, but can be used for showing technical
information passed through in a variable, for example back-end error information, lists of files, etc.
Variable information should always be introduced with a lead-in sentence.
See Also