ViewScheduleDeleteSegment Method

Deletes a schedule segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void DeleteSegment(
	int segmentIndex
)

Parameters

segmentIndex  Int32
Zero-based index of the segment.
Exceptions
ExceptionCondition
ArgumentException The segment index should start from 0 and be less than the total segment count.
InvalidOperationException This ViewSchedule is not split yet.
Remarks
If the last segment is deleted, the previous one will be the last one and its height will be modified to unlimited. If one segment is deleted when there are only two segments, all the instances will be deleted and the schedule will become unsplit again.
See Also