ColumnAttachmentJustification Enumeration |
Control the column extent in cases where the target is not a uniform height.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ColumnAttachmentJustification
Public Enumeration ColumnAttachmentJustification
public enum class ColumnAttachmentJustification
type ColumnAttachmentJustification
MembersMember name | Value | Description |
---|
Minimum | 0 |
Minimize the column extent, so that it comes in contact with the target but does not intersect.
|
Midpoint | 1 |
Extend the column until its midpoint contacts the target.
|
Maximum | 2 |
Extend the column until it is completely covered by the target, intersecting it if necessary.
|
Tangent | 3 |
For slanted columns only. Extend the column until its driving curve contacts the target, then cut the column
with a plane tangent to the target at that contact point.
|
See Also