CableTraySizesAddSize Method

Inserts a new MEPSize into the cable tray sizes. For cable tray, the nominal diameter of MEPSize is used .

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddSize(
	MEPSize sizeInfo
)

Parameters

sizeInfo  MEPSize
The new MEPSize to be added.
Exceptions
ExceptionCondition
ArgumentException There is already the same size in the size set.
ArgumentNullException A non-optional argument was null
InvalidOperationException The function is called during iterating the size set.
See Also