MaterialPropertyPathType Enumeration |
Enum class indicating kinds of paths which ExternalFileReferenceType.Material
references can have.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum MaterialPropertyPathType
Public Enumeration MaterialPropertyPathType
public enum class MaterialPropertyPathType
type MaterialPropertyPathType
MembersMember name | Value | Description |
---|
General | 0 |
General image, for various material types
|
Transparency | 1 |
Transparency image, for generic materials
|
Cutouts | 2 |
Cutouts image, for generic or metal materials
|
Bump | 3 |
Bump pattern, for generic materials
|
FinishBumps | 4 |
Finish bumps, pattern for various material types
|
ReliefPattern | 5 |
Relief pattern, for various material types
|
Weathering | 6 |
Weathering image, for concrete materials
|
See Also