RebarFreeFormAccessorCanBeHookNormal Method |
A vector can be hook normal if for a bar specified by index, the bar direction is not parallel with the vector.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanBeHookNormal(
int barIndex,
int end,
XYZ normal
)
Public Function CanBeHookNormal (
barIndex As Integer,
end As Integer,
normal As XYZ
) As Boolean
public:
bool CanBeHookNormal(
int barIndex,
int end,
XYZ^ normal
)
member CanBeHookNormal :
barIndex : int *
end : int *
normal : XYZ -> bool
Parameters
- barIndex Int32
-
The index of bar for which it will try to see if hook normal is applicable.
- end Int32
-
The end of bar. Should be 0 for start, 1 for end.
- normal XYZ
-
The hook plane normal that will be tested.
Return Value
Boolean
Exceptions
See Also