EntityClear(Field) Method |
Resets the field to its default value.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Clear(
Field field
)
Public Sub Clear (
field As Field
)
public:
void Clear(
Field^ field
)
member Clear :
field : Field -> unit
Parameters
- field Field
-
The field to clear.
ExceptionsException | Condition |
---|
ArgumentException |
The Field belongs to a different Schema from this Entity, or this Entity is invalid.
-or-
This field's subschema prevents writing.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The default value is zero for numeric fields, invalid value for identifiers and
entities, and empty for strings and containers.
See Also