RoutingPreferenceErrorLevel Enumeration |
An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RoutingPreferenceErrorLevel
Public Enumeration RoutingPreferenceErrorLevel
public enum class RoutingPreferenceErrorLevel
type RoutingPreferenceErrorLevel
MembersMember name | Value | Description |
---|
None | 0 |
Do not post any warning or error if there is no rule in the routing preference satisfying the current condition.
|
Warning | 1 |
Post Revit warnings if there is no rule in the routing preference satisfying the current condition.
|
Error | 2 |
Post Revit errors if there is no rule in the routing preference satisfying the current condition.
|
See Also