FamilyInstanceRoom Property |
The room in which the instance is located (during the last phase of the project).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Room Room { get; }
Public ReadOnly Property Room As Room
Get
public:
property Room^ Room {
Room^ get ();
}
member Room : Room with get
Property Value
Room
RemarksThis property will be the first room encountered that contains the instance. If more than
one room includes this point in its volume only the first one is returned.
If no room is found that contains the instance, or if phase does not apply to this FaimlyInstance,
this property is
.
This property should not be used for door or window instances, which are placed on the boundary or
between rooms. Use the
FromRoom and
ToRoom properties instead.
See Also