BuildingEnvelopeAnalyzerGetCenterPointsForConnectedGridCellsInSpaceVolume Method |
Returns the collection of connected cells in an enclosed space volume.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<XYZ> GetCenterPointsForConnectedGridCellsInSpaceVolume(
int spaceVolume
)
Public Function GetCenterPointsForConnectedGridCellsInSpaceVolume (
spaceVolume As Integer
) As IList(Of XYZ)
public:
IList<XYZ^>^ GetCenterPointsForConnectedGridCellsInSpaceVolume(
int spaceVolume
)
member GetCenterPointsForConnectedGridCellsInSpaceVolume :
spaceVolume : int -> IList<XYZ>
Parameters
- spaceVolume Int32
-
Return Value
IListXYZ
The center points for the connected analytical grid cells in the enclosed space volume.
Remarks
This method requires the building envelope analyzer method created with
the option set to compute enclosed space volumes.
See Also