ISelectionFilterAllowReference Method |
Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.
Namespace: Autodesk.Revit.UI.SelectionAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool AllowReference(
Reference reference,
XYZ position
)
Function AllowReference (
reference As Reference,
position As XYZ
) As Boolean
bool AllowReference(
Reference^ reference,
XYZ^ position
)
abstract AllowReference :
reference : Reference *
position : XYZ -> bool
Parameters
- reference Reference
- A candidate reference in selection operation.
- position XYZ
- The 3D position of the mouse on the candidate reference.
Return Value
BooleanReturn true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.
RemarksIf an exception is thrown from this method, the element will not be permitted to be selected.
See Also