FailuresAccessorSetFailureHandlingOptions Method

Sets failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFailureHandlingOptions(
	FailureHandlingOptions options
)

Parameters

options  FailureHandlingOptions
The failure handling options to be set for the transaction currently being finished.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
If used with returning ProceedWithRollback from (pre)processing, allows to dismiss errors and roll back transaction without any further failures processing and silently for the user.
See Also